Jump to content

Rulex Platform not working on VM


Recommended Posts

Hi Team Rulex,

We have installed Rulex on VM but when we try to open, this is not allowing us to create any flow.

Basically we don’t see Factory and Info point option on this.

Please let us know how we can fix this and start using application.

PFA image

Thanks in advance.

BR,

Pushkar

Untitled.png

Link to comment
Share on other sites

Hi Pushkar,

we've been able to open Platform with your licence and see all components. 

Are you sure that the VM is able to reach our license manager? To check it, you can run the following command on windows PowerShell:

Invoke-WebRequest -Uri ("https://licensemanager.rulex.cloud/license/login?productkey=<INSERT YOUR PRODUCT KEY>&sessionid="+(new-guid)+"&timestamp="+(Get-Date (Get-Date).ToUniversalTime() -UFormat '+%Y-%m-%dT%H:%M:%S.000Z')) -Method 3

Additionally, if you send us your Platform log on a private message we can further investigate

Keep us updated

Link to comment
Share on other sites

4 minutes ago, Enrico said:

Hi Pushkar,

we've been able to open Platform with your licence and see all components. 

Are you sure that the VM is able to reach our license manager? To check it, you can run the following command on windows PowerShell:

Invoke-WebRequest -Uri ("https://licensemanager.rulex.cloud/license/login?productkey=<INSERT YOUR PRODUCT KEY>&sessionid="+(new-guid)+"&timestamp="+(Get-Date (Get-Date).ToUniversalTime() -UFormat '+%Y-%m-%dT%H:%M:%S.000Z')) -Method 3

Additionally, if you send us your Platform log on a private message we can further investigate

Keep us updated

Hi Enrico, Thanks for reply.

May I know how to get platform log?

Link to comment
Share on other sites

42 minutes ago, Pushkar said:

Hi Enrico, After running powershell I can see this one:

PS C:\Users\MW618FY> Invoke-WebRequest -Uri ("https://licensemanager.rulex.cloud/license/login?productkey=&sessionid="+(new-guid)+"&timestamp="+(Get-Date (Get-Date).ToUniversalTime() -UFormat '+%Y-%m-%dT%H:%M:%S.000Z')) -Method 3


StatusCode        : 200
StatusDescription : OK

RawContent        : HTTP/1.1 200 OK
                    Connection: keep-alive
                    Access-Control-Allow-Origin: *
                    Access-Control-Allow-Headers: x-requested-with, content-range, content-disposition
                    Access-Control-Allow-Methods: POST, GET, OP...
Forms             : {}
Headers           : {[Connection, keep-alive], [Access-Control-Allow-Origin, *], [Access-Control-Allow-Headers, x-requested-with, content-range, content-disposition], [Access-Control-Allow-Methods, POST, GET, OPTIONS]...}
Images            : {}
InputFields       : {}
Links             : {}
ParsedHtml        : mshtml.HTMLDocumentClass
RawContentLength  : 1285

From this it seems that the VM is able to reach our license manager, we will wait for logs on private chat 

Please, remember that all the information shared in Forums are public! 

Link to comment
Share on other sites

1 minute ago, Enrico said:

From this it seems that the VM is able to reach our license manager, we will wait for logs on private chat 

Please, remember that all the information shared in Forums are public! 

you mean even if I send message from Platform log to you will be public also?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...